Kategorie
Bez kategorii

Solving CrackMapExec ver 5.0.2dev installation error related to asn1crypto

Solving CrackMapExec ver 5.0.2dev installation error related to asn1crypto

Below you will find a solution to the installation issue of CrackMapExec 5.0.2dev (CME), related to past versions of asn1crypto (< 1.3.0). It occured on a Kali Linux 2020.1 VM, while following along with the instructions from Github source (link below).

https://github.com/byt3bl33d3r/CrackMapExec/wiki/Installation#debianubuntu

Steps to reproduce the behavior:

#~ apt-get install -y libssl-dev libffi-dev python-dev build-essential
#~ git clone --recursive https://github.com/byt3bl33d3r/CrackMapExec
#~ cd CrackMapExec
#~ python3 setup.py install

error: asn1crypto>=1.3.0 is required by {‚minikerberos’}:

Installed /usr/local/lib/python3.7/dist-packages/crackmapexec-5.0.2.dev0-py3.7.egg
Processing dependencies for crackmapexec==5.0.2.dev0
error: asn1crypto 0.24.0 is installed but asn1crypto>=1.3.0 is required by {'minikerberos'}

Now as we know the cause, all we need to do is

How can we solve it?

To upgrade the asn1crypto library, ensure you’ve already installed pip3 via your system package manager:

#~ apt update
#~ apt install python3-pip

then follow the set of commands visible below:

#~ pip3 install asn1crypto==1.3.0
#~ pip3 install asn1crypto --upgrade --user

and:

#~ pip3 install prompt-toolkit==2.0.9

After a successful upgrade procedure, once again repeat this in the CrackMapExec directory:

root@kali:/home/kali/CrackMapExec# python3 setup.py install

Now that you’ve got the CME tool installed, you can use it to enumerate the network of live Windows hosts.

References

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *